Knowledge Base

Welcome to The Carlisle Group's Knowledge Base.

Search or Ask a Question

This is a keyword search that looks for matching articles that contain one or more words specifically by a user in articles’ tags, title and content. Admin writes brief intro content here via admin end. If you are unable to find an answer to your issue, please submit an issue here.

Back to Articles List

Data Tables in CAS | CAS

Added: 01/13/2015; Last Modified: 01/13/2015; Visits:2,110

CAS can store static table data in Data Tables.  These can be used as lookup tables against keys in the current CAS file.   There are no rows and column size restrictions but it's a good idea to avoid large datasets.  Large data tables significantly increase file size and time it takes to save the file.  In situations where large lookup tables are necessary another CAS file can be used instead.

 

Creating a new Data Table

  1. Go to the "Data Tables" folder under "Repoirts and Programs->System Folders"

     
     
  2. Create a new Data Table by right-clicking in the right pane.


     
  3.  Once your table is created, open its properties by clicking "Properties" on its right-click context menu.



    You will get a default new data table.


     
  4.  Nexy you need to define your rows and columns.
     
  5. The "Tools" menu has options to add, delete and insert columns.


     
  6. You can modify a column type and name by double-clicking on column header title.


     
  7.  Row titles are modified  by double-clicking on the row name column.

     
     
  8. Once your table is defined, data can by manully entered or a gird paste operation can be used.


     

 

 

The "lookup" user function is used to access the Data Table from your epxressions.